Setting IP Public WireGuard di Router MikroTik

DateMay 28, 2024

Estimated reading time: 3 minutes

Setting IP Public WireGuard di Router MikroTik

Pendahuluan

IP Public (Alamat IP Publik) dan WireGuard adalah dua hal yang berbeda fungsinya dalam jaringan internet:

IP Public

  • Pengertian: Alamat IP Publik adalah label unik yang diberikan kepada perangkat Anda untuk bisa dikenali dan diakses secara global di internet.
  • Fungsinya: IP Publik dibutuhkan untuk berbagai keperluan seperti:
    • Menjalankan server, seperti web server atau email server.
    • Membuat website yang bisa diakses publik.
    • Menggunakan layanan VPN dengan mode server
    • Mengakses perangkat Anda dari jarak jauh.
  • Cara Mendapatkan: Biasanya didapatkan dari Internet Service Provider (ISP) Anda. Namun, tidak semua provider menawarkan IP Publik secara gratis, terkadang perlu berlangganan paket khusus.

WireGuard

  • Pengertian: WireGuard adalah protokol VPN (Virtual Private Network) terbaru yang menawarkan kecepatan tinggi dan keamanan yang baik.
  • Fungsinya: WireGuard mengenkripsikan data internet Anda sehingga aktivitas browsing Anda menjadi aman dan Koneksi Anda seperti terowongan pribadi yang aman ke internet.
  • Keunggulan WireGuard:
    • Cepat: Memiliki kode yang efisien sehingga menawarkan kecepatan transfer data yang tinggi
    • Aman: Menggunakan standar enkripsi modern dan memiliki basis kode yang ringkas sehingga meminimalisir celah keamanan
    • Mudah Digunakan: Konfigurasinya lebih sederhana dibandingkan protokol VPN lain.

Singkatnya:

  • IP Public adalah alamat rumah Anda di dunia internet, sedangkan WireGuard adalah teknologi pengaman yang membuat komunikasi Anda seperti di dalam rumah pribadi yang aman.

Langkah-langkah Instalasi

1. Unduh file konfigurasi WireGuard

Unduh file konfigurasi di Client Area lalu buka menggunakan editor teks apa pun, Misal dengan Notepad++.

2. Masuk ke Mikrotik

Anda dapat menggunakan Terminal langsung di Winbox atau menggunakan SSH pada Linux, macOS, atau PowerShell pada Windows.

3. Membuat Interface WireGuard Baru

Gunakan baris perintah pada terminal, masukkan teks berikut dan ketuk <enter>.

Note: Untuk menemukan kode private key Anda, cari baris yang dimulai dengan PrivateKey= di file konfigurasi WireGuard yang Anda unduh pada langkah 1.

/interface wireguard
add listen-port=13231 mtu=1420 name=wireguard-inet private-key=”kode private anda”

4. Tambahkan IP Address pada interface Wireguard yang baru saja anda buat:

/ip address
add address= x.x.x.x interface=wireguard-inet network= x.x.x.x

Note: Untuk menemukan ip address Anda, cari baris yang dimulai dengan Address= di file konfigurasi WireGuard yang Anda unduh pada langkah 1.

5. Tambahkan WireGuard server as a peer

Tambahkan endpoint address, endpoint port, dan public key dari file konfigurasi WireGuard yang Anda unduh pada langkah 1. Cari bagian PublicKey= dan Endpoint=

Contoh, pada file konfigurasi terdapat Endpoint=pub.domain.net:51820, masukan endpoint-address= pub.domain.net dan endpoint-port=51820

/interface wireguard peers
add allowed-address=0.0.0.0/0 endpoint-address=x.x.x.x endpoint-port=xxxxx interface=wireguard-inet persistent-keepalive=10s public-key="kode public anda" 

6. Aktifkan masquerade untuk interface WireGuard

Note: Pengaturan ini saya asumsikan bahwa anda masih menggunakan IP Address lokal bawaan MikroTik, Namun apabila anda sudah merubahnya silahkan sesuaikan pada bagian scr-address=

/ip firewall nat
add action=masquerade chain=srcnat out-interface=wireguard-inet src-address=192.168.88.0/24

7. Menambahkan setingan DNS

/ip dns
set servers=8.8.8.8,1.1.1.1

Kesimpulan

Dengan mengikuti langkah-langkah di atas, Anda telah berhasil menginstal IP Public di Mikrotik dengan mode WireGuard. Anda sekarang dapat menggunakan IP Public tersebut untuk berbagai keperluan.

Leave a Reply